Solved Error Seo Add-on

upgrade

Licensed
Licensed
SEO Optimization
Joined
Jan 12, 2021
Messages
2
Reaction score
0
Hi Goodmorning!

I recently updated your plugin on our XenForo installation which is also at the latest version available.
I have updated all our Add-ons including the XenForo media library.

However I keep getting an error where your addon goes into crisis with the media gallery (at least that's how it seems to me)

Code:
Log errore server
Error: Template public:xfmg_media_view error: Call to a member function setEntity() on null src/addons/XenSoluce/SEOOptimization/Template/TemplaterSetup.php:80
Generated by: Account sconosciuto 10 Gennaio 2023 alle 00:48
Stack trace
#0 src/addons/XenSoluce/SEOOptimization/Template/TemplaterSetup.php(30): XenSoluce\SEOOptimization\Template\TemplaterSetup->getSEOHandler(Object(XenSoluce\SEOOptimization\XFMG\Entity\MediaItem), Object(ThemeHouse\UIX\XF\Template\Templater))
#1 src/XF/Template/Templater.php(1129): XenSoluce\SEOOptimization\Template\TemplaterSetup->fnXsChangeTitle(Object(ThemeHouse\UIX\XF\Template\Templater), false, Object(XenSoluce\SEOOptimization\XFMG\Entity\MediaItem))
#2 internal_data/code_cache/templates/l5/s6/public/xfmg_media_view.php(7): XF\Template\Templater->func('change_title', Array, false)
#3 src/XF/Template/Templater.php(1652): XF\Template\Templater->{closure}(Object(ThemeHouse\UIX\XF\Template\Templater), Array, NULL)
#4 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('xfmg_media_view', Array)
#5 src/XF/Mvc/Renderer/Html.php(50): XF\Template\Template->render()
#6 src/XF/Mvc/Dispatcher.php(460): XF\Mvc\Renderer\Html->renderView('XFMG:Media\\View', 'public:xfmg_med...', Array)
#7 src/XF/Mvc/Dispatcher.php(442): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#8 src/XF/Mvc/Dispatcher.php(402): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#9 src/XF/Mvc/Dispatcher.php(60): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#10 src/XF/App.php(2483): XF\Mvc\Dispatcher->run()
#11 src/XF.php(524): XF\App->run()
#12 index.php(20): XF::runApp('XF\\Pub\\App')
#13 {main}
Stato richiesta
array(4) {
  ["url"] => string(31) "/media/bruniti-giulia-68p.1064/"
  ["referrer"] => bool(false)
  ["_GET"] => array(1) {
    ["/media/bruniti-giulia-68p_1064/"] => string(0) ""
  }
  ["_POST"] => array(0) {
  }
}

&

Code:
Stack trace
#0 src/addons/XenSoluce/SEOOptimization/Template/TemplaterSetup.php(30): XenSoluce\SEOOptimization\Template\TemplaterSetup->getSEOHandler(Object(XenSoluce\SEOOptimization\XFMG\Entity\MediaItem), Object(ThemeHouse\UIX\XF\Template\Templater))
#1 src/XF/Template/Templater.php(1129): XenSoluce\SEOOptimization\Template\TemplaterSetup->fnXsChangeTitle(Object(ThemeHouse\UIX\XF\Template\Templater), false, Object(XenSoluce\SEOOptimization\XFMG\Entity\MediaItem))
#2 internal_data/code_cache/templates/l5/s6/public/xfmg_media_view.php(7): XF\Template\Templater->func('change_title', Array, false)
#3 src/XF/Template/Templater.php(1652): XF\Template\Templater->{closure}(Object(ThemeHouse\UIX\XF\Template\Templater), Array, NULL)
#4 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('xfmg_media_view', Array)
#5 src/XF/Mvc/Renderer/Html.php(50): XF\Template\Template->render()
#6 src/XF/Mvc/Dispatcher.php(460): XF\Mvc\Renderer\Html->renderView('XFMG:Media\\View', 'public:xfmg_med...', Array)
#7 src/XF/Mvc/Dispatcher.php(442): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#8 src/XF/Mvc/Dispatcher.php(402): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#9 src/XF/Mvc/Dispatcher.php(60): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#10 src/XF/App.php(2483): XF\Mvc\Dispatcher->run()
#11 src/XF.php(524): XF\App->run()
#12 index.php(20): XF::runApp('XF\\Pub\\App')
#13 {main}
 

CRUEL-MODZ

Administrator
Staff member
Administrator
Moderator
Licensed
Joined
Jul 8, 2019
Messages
949
Reaction score
385
Hello,

This is fixed in the 2.6.2 Fx 3 version, thank your for reporting this ! ;)

Regards, CRUEL-MODZ
 
Solution

upgrade

Licensed
Licensed
SEO Optimization
Joined
Jan 12, 2021
Messages
2
Reaction score
0
Updated and this above error is fixed!
Thank you

But now this only comes up on a couple of threads.

Code:
ErrorException: Template error: [E_WARNING] Attempt to read property "message" on null src/addons/XenSoluce/SEOOptimization/SEO/Thread.php:57
Generated by: Account sconosciuto 16 Gennaio 2023 alle 22:18
Stack trace
#0 src/addons/XenSoluce/SEOOptimization/SEO/Thread.php(57): XF\Template\Templater->handleTemplateError(2, '[E_WARNING] Att...', '/home/nginx/dom...', 57)
#1 src/addons/XenSoluce/SEOOptimization/SEO/AbstractHandler.php(167): XenSoluce\SEOOptimization\SEO\Thread->description()
#2 src/addons/XenSoluce/SEOOptimization/SEO/Thread.php(166): XenSoluce\SEOOptimization\SEO\AbstractHandler->changeDescription(false)
#3 src/addons/XenSoluce/SEOOptimization/Template/TemplaterSetup.php(57): XenSoluce\SEOOptimization\SEO\Thread->changeDescription(false)
#4 src/XF/Template/Templater.php(1129): XenSoluce\SEOOptimization\Template\TemplaterSetup->fnXsChangeDescription(Object(ThemeHouse\UIX\XF\Template\Templater), false, Object(XFMG\XF\Entity\Thread))
#5 internal_data/code_cache/templates/l5/s6/public/thread_view.php(692): XF\Template\Templater->func('change_descript...', Array, false)
#6 src/XF/Template/Templater.php(1652): XF\Template\Templater->{closure}(Object(ThemeHouse\UIX\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#7 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('thread_view', Array)
#8 src/XF/Mvc/Renderer/Html.php(50): XF\Template\Template->render()
#9 src/XF/Mvc/Dispatcher.php(460): XF\Mvc\Renderer\Html->renderView('XF:Thread\\View', 'public:thread_v...', Array)
#10 src/XF/Mvc/Dispatcher.php(442): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#11 src/XF/Mvc/Dispatcher.php(402): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#12 src/XF/Mvc/Dispatcher.php(60): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#13 src/XF/App.php(2483): XF\Mvc\Dispatcher->run()
#14 src/XF.php(524): XF\App->run()
#15 index.php(20): XF::runApp('XF\\Pub\\App')
#16 {main}
 

CRUEL-MODZ

Administrator
Staff member
Administrator
Moderator
Licensed
Joined
Jul 8, 2019
Messages
949
Reaction score
385
Hello,

Updated and this above error is fixed!
Thank you

But now this only comes up on a couple of threads.

Code:
ErrorException: Template error: [E_WARNING] Attempt to read property "message" on null src/addons/XenSoluce/SEOOptimization/SEO/Thread.php:57
Generated by: Account sconosciuto 16 Gennaio 2023 alle 22:18
Stack trace
#0 src/addons/XenSoluce/SEOOptimization/SEO/Thread.php(57): XF\Template\Templater->handleTemplateError(2, '[E_WARNING] Att...', '/home/nginx/dom...', 57)
#1 src/addons/XenSoluce/SEOOptimization/SEO/AbstractHandler.php(167): XenSoluce\SEOOptimization\SEO\Thread->description()
#2 src/addons/XenSoluce/SEOOptimization/SEO/Thread.php(166): XenSoluce\SEOOptimization\SEO\AbstractHandler->changeDescription(false)
#3 src/addons/XenSoluce/SEOOptimization/Template/TemplaterSetup.php(57): XenSoluce\SEOOptimization\SEO\Thread->changeDescription(false)
#4 src/XF/Template/Templater.php(1129): XenSoluce\SEOOptimization\Template\TemplaterSetup->fnXsChangeDescription(Object(ThemeHouse\UIX\XF\Template\Templater), false, Object(XFMG\XF\Entity\Thread))
#5 internal_data/code_cache/templates/l5/s6/public/thread_view.php(692): XF\Template\Templater->func('change_descript...', Array, false)
#6 src/XF/Template/Templater.php(1652): XF\Template\Templater->{closure}(Object(ThemeHouse\UIX\XF\Template\Templater), Array, Object(XF\Template\ExtensionSet))
#7 src/XF/Template/Template.php(24): XF\Template\Templater->renderTemplate('thread_view', Array)
#8 src/XF/Mvc/Renderer/Html.php(50): XF\Template\Template->render()
#9 src/XF/Mvc/Dispatcher.php(460): XF\Mvc\Renderer\Html->renderView('XF:Thread\\View', 'public:thread_v...', Array)
#10 src/XF/Mvc/Dispatcher.php(442): XF\Mvc\Dispatcher->renderView(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#11 src/XF/Mvc/Dispatcher.php(402): XF\Mvc\Dispatcher->renderReply(Object(XF\Mvc\Renderer\Html), Object(XF\Mvc\Reply\View))
#12 src/XF/Mvc/Dispatcher.php(60): XF\Mvc\Dispatcher->render(Object(XF\Mvc\Reply\View), 'html')
#13 src/XF/App.php(2483): XF\Mvc\Dispatcher->run()
#14 src/XF.php(524): XF\App->run()
#15 index.php(20): XF::runApp('XF\\Pub\\App')
#16 {main}
This is a strange mistake. This would mean that you do not have a firstpost :unsure:
I will share an update, not sure which will fix your problem ^^

Regards, CRUEL-MODZ
 
Top Bottom