[Xen-Soluce] Avatar Gallery

Add-on [Xen-Soluce] Avatar Gallery 2.1.5

No permission to download
Hello,

Hey, I have tested at localhost on my PC, and only one add-on is currently installed without any add-ons. The register page doesn't show up anymore. Might be bug known possible?

Could you test it on your local host? If this happens to you then it's a known issue in the 2.1.12 and 2.1.13 versions.
I am currently on holiday, unfortunately the localhost that I have on the PC that I currently have works very badly (the hard disk has a bug), I will see to reinstall the localhost either tomorrow or in the week :)

Regards, CRUEL-MODZ
 
Last edited:
Hey, I have tested at localhost on my PC, and only one add-on is currently installed without any add-ons. The register page doesn't show up anymore. Might be bug known possible?

Could you test it on your local host? If this happens to you then it's a known issue in the 2.1.12 and 2.1.13 versions.
Hello, what's your XenForo version, 2.1.12 ? If so, this add-on now require 2.2.0 and + to be installed :

Regards, SyTry
 
Last edited by a moderator:
Hello,


I am currently on holiday, unfortunately the localhost that I have on the PC that I currently have works very badly (the hard disk has a bug), I will see to reinstall the localhost either tomorrow or in the week :)

Regards, CRUEL-MODZ
Great!

Hello, what's your XenForo version, 2.1.12 ? If so, this add-on now require 2.2.0 and + to be installed :

Regards, SyTry
I apologize, I mistyped that version, I'd say v2.2.12
 
Great!


I apologize, I mistyped that version, I'd say v2.2.12
Hello,

Oh ok, via the ACP, can you check if all the template modification applied by our add-on is enabled ? If you can make a screenshot if possible, this will help us aha ! :)

Regards, SyTry
 
Last edited by a moderator:
Hello,

Oh ok, via the ACP, can you check if all the template modification applied by our add-on is enabled ? If you can make a screenshot if possible, this will help us aha ! :)

Regards, SyTry
Here, when add-on is installed there are no outdated templates.
kG9qhd3.png


aM1Iomf.png
 
Here, when add-on is installed there are no outdated templates.
kG9qhd3.png


aM1Iomf.png
Hello,

For register_form you have 0/1/0 which mean that the template modification is not applied. You have no other add-on, right ?

Regards, SyTry
 
Last edited by a moderator:
Hello,

I just tested on my local and personally it works with the last update of XF.
Did you check : Screenshot
Have you added images to data/gallery_avatars ?

Regards, CRUEL-MODZ
Oh, I forgot to add a picture on the gallery folder, and should show up at localhost so yes, but our site doesn't show up anymore. I'll try disabling all of the add-ons and check again if one add-on has been found an issue that causes to add-on trigger would not adjust the template then I'll report this to you.
 
Hey CRUEL-MODZ, SyTry, I found out that the two add-ons caused to stopped working X-S Avatar Gallery issue. Easy User Ban 2 by Siropu and [OzzModz] Gif Avatar Permissions are currently enabled when you choose the avatar to get the error: A server error occurred. Please try again later.

If both add-ons are disabled then you should able to register and choose avatar without issue.

Only if [OzzModz] Gif Avatar Permissions is enabled then will be an error there,

Code:
LogicException: No source file for avatar set src/XF/Service/User/Avatar.php:191
Generated by: test Feb 8, 2024 at 5:09 PM
Stack trace
#0 src/addons/XenSoluce/AvatarGallery/XF/Pub/Controller/Register.php(99): XF\Service\User\Avatar->updateAvatar()
#1 src/XF/Pub/Controller/Register.php(437): XenSoluce\AvatarGallery\XF\Pub\Controller\Register->finalizeRegistration(Object(SV\PasswordTools\XF\Entity\User))
#2 src/addons/XenSoluce/AvatarGallery/XF/Pub/Controller/Register.php(79): XF\Pub\Controller\Register->actionRegister()
#3 src/XF/Mvc/Dispatcher.php(352): XenSoluce\AvatarGallery\XF\Pub\Controller\Register->actionRegister(Object(XF\Mvc\ParameterBag))
#4 src/XF/Mvc/Dispatcher.php(259): XF\Mvc\Dispatcher->dispatchClass('XF:Register', 'Register', Object(XF\Mvc\RouteMatch), Object(XenSoluce\AvatarGallery\XF\Pub\Controller\Register), NULL)
#5 src/XF/Mvc/Dispatcher.php(115): XF\Mvc\Dispatcher->dispatchFromMatch(Object(XF\Mvc\RouteMatch), Object(XenSoluce\AvatarGallery\XF\Pub\Controller\Register), NULL)
#6 src/XF/Mvc/Dispatcher.php(57): XF\Mvc\Dispatcher->dispatchLoop(Object(XF\Mvc\RouteMatch))
#7 src/XF/App.php(2487): XF\Mvc\Dispatcher->run()
#8 src/XF.php(524): XF\App->run()
#9 index.php(20): XF::runApp('XF\\Pub\\App')
#10 {main}
 
Hi, can you please please make it auto set the vatar picked randomly upon sign up?

I'm willing to donate a few bucks for this to be added <3

Also question, how do I upload the avatars when I'm on xenForo Cloud?
 
Last edited by a moderator:
Top Bottom